Backup and selfmade ISO?

Post your comments, questions, bug reports or suggest new features for alphaOS
Keruba
Apprentice
Posts: 16
Joined: 30 Dec 2013, 18:31

Backup and selfmade ISO?

Postby Keruba » 09 Jan 2014, 21:06

Hello Again.

So i have now set up everything properly in my system and installed all the software, wallpapers and stuff i need. :)

When i want to do a backup do i have simply put the savefile on a usb, and copy it back in later in case of a crash or updating?

Or, what would be the coolest thing, is it even possible to make an ISO from my setup and burn it on a stick to make it bootable? That would be terrific.

Sorry for the boring question guys, i`m still new to all this.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: Backup and selfmade ISO?

Postby Scooby » 10 Jan 2014, 13:50

Keruba wrote:When i want to do a backup do i have simply put the savefile on a usb, and copy it back in later in case of a crash or updating?

Yes

Keruba wrote:Or, what would be the coolest thing, is it even possible to make an ISO from my setup and burn it on a stick to make it bootable? That would be terrific.

You could, but then you'll have to extract ISO again?
Better to copy whole base directory to a bootable USB( bootable USB is easy to setup with grub4dos or grub2)

you can then turn savefile into a squash .sb file and put it in alphaos/modules
(you could use sbcomb for this http://alphaos.tuxfamily.org/forum/viewtopic.php?f=8&t=779 )

Actually I did make a mod on alphaOS ISO to make it bootable directly from ISO file with grub2.
If you're interested in this I will help you.

9arkb0y
Apprentice
Posts: 12
Joined: 08 Jan 2014, 13:49

Re: Backup and selfmade ISO?

Postby 9arkb0y » 12 Jan 2014, 17:34

a tuto about this could be fine. i customize alphaos to share with my friends
mkisofs -o .....

in my lappy works great the .iso but my friends pc have this error "partition not found"

any help.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: Backup and selfmade ISO?

Postby Scooby » 12 Jan 2014, 18:55

9arkb0y wrote:i customize alphaos to share with my friends
mkisofs -o .....

in my lappy works great the .iso but my friends pc have this error "partition not found"

any help.


Does the normal alphaos iso run on your friends "lappy"?

If not what mods have you made?

Did you use a squashed savefile? Then
perhaps you added something that depends on a partition
on your comp but that is unavailible on your friends "lappy"

When in boot process do you get error?

I guess youre running frugal?

9arkb0y
Apprentice
Posts: 12
Joined: 08 Jan 2014, 13:49

Re: Backup and selfmade ISO?

Postby 9arkb0y » 12 Jan 2014, 20:07

Scooby wrote:
9arkb0y wrote:i customize alphaos to share with my friends
mkisofs -o .....

in my lappy works great the .iso but my friends pc have this error "partition not found"

any help.


Does the normal alphaos iso run on your friends "lappy"?

If not what mods have you made?

Did you use a squashed savefile? Then
perhaps you added something that depends on a partition
on your comp but that is unavailible on your friends "lappy"

When in boot process do you get error?

I guess youre running frugal?




i send a link to original alphaos iso to see if is problem of my mod.

i customized alphaOS with xbmc and some plugins is a frugal copy to usb-live to my disk and to integrate savefile to the system i made sbcomb --savefile... like i asked yesterday :roll:
one time made i delete changes.fs4

i made the iso in 2 different ways
one with mkisofs -0 alphaosMod.iso /mnt/live/... works fine any errors and 2 method was copy all the data in my unmount partition and use a iso maker software in windows.

both works fine in my laptop but

the list of apps
xbmc
gparted
flashplayer
udevil
udisks


im going to make it again (for this i love this distro :D )

pd: we have to work in a script like make_a_iso.sh, porteus have one.. maybe someone can modify this script because i think have same structure porteus and alphaos.

sorry for my english and 1000 thankx for this amazing distro.

EDIT: my friend download alphaos orginal iso and dont works then have to be his usb or other problem.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: Backup and selfmade ISO?

Postby Scooby » 12 Jan 2014, 21:10

9arkb0y wrote:i made the iso in 2 different ways
one with mkisofs -0 alphaosMod.iso /mnt/live/... works fine any errors and 2 method was copy all the data in my unmount partition and use a iso maker software in windows.

I use
mkisofs -o alphaosMod.iso -v -J -R -D -A "AlphaOSMOD" -V "AlphaOSMOD CD/DVD" -no-emul-boot -boot-info-table -boot-load-size 4 -b alphaos/boot/isolinux.bin -c alphaos/boot/boot.cat iso-root/

I only mod initrfs.img though, I think the other hacks I do is better added as bundle.
The bundle will overshadow the original iso stuff anyway.
But I gues that is a question of taste.

9arkb0y wrote:pd: we have to work in a script like make_a_iso.sh, porteus have one.. maybe someone can modify this script because i think have same structure porteus and alphaos.

There are simiar scripts for slax. I have my own very crude script-hacks depending on existing mountpoints and so on
but I guess they could be cleaned. Maybe you can put something together?

9arkb0y wrote:sorry for my english and 1000 thankx for this amazing distro.

All thanks should go to Sim.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 4 guests

cron