[SOLVED] Wireless problems workaround

Post your comments, questions, bug reports or suggest new features for alphaOS
fredx
Apprentice
Posts: 7
Joined: 25 Sep 2013, 20:52

[SOLVED] Wireless problems workaround

Postby fredx » 23 Oct 2013, 15:59

Hi All
It has been puzzling me for some time that from v8 on wireless connection doesn't work.(I've noticed others have the same problem).
I have Intel Pro/Wireless (ipw2200)
I've tried lots of options: different versions of dhcpcd, wpa_supplicant, frisbee; manually connect, etc..
Also tried some tips from this forum.
Nothing worked...
But eventually I found this simple workaround:

Code: Select all

# Copy kmod and modprobe (symlink to kmod) from /bin to /usr/bin
cp -a /bin/modprobe /usr/bin
cp -a /bin/kmod /usr/bin
# Create symlink sbin to usr/bin on the filesystem root.
cd /
ln -s usr/bin sbin



And try to connect through frisbee (maybe a reboot with savefile is required first)
I'm not sure why but it worked for me. :D
Hope this works for others too.
Thanks for alphaOS, now it's perfect for me with working wireless.

EDIT: Even more simple (as Marv suggested):
Create symlink /sbin to /bin does the trick:

Code: Select all

# Create symlink sbin to /bin on the filesystem root.
cd /
ln -s bin sbin
Last edited by fredx on 29 Oct 2013, 20:00, edited 2 times in total.

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: Wireless problems workaround

Postby simargl » 23 Oct 2013, 17:45

Hi fredx, I'm glad you solved that problem. :)

It is probably because of some script still using old modprobe location under /sbin, but then question is, why it worked for others. I don't use wireless, so for me it remains mystery.

fredx
Apprentice
Posts: 7
Joined: 25 Sep 2013, 20:52

Re: Wireless problems workaround

Postby fredx » 23 Oct 2013, 21:29

Because I don't really like mysteries I've been digging a little deeper.
When comparing booting with or without savefile lsmod shows 4 more modules loaded when i applied my "fix":

michael_mic 1394 8
arc4 1404 4
ecb 1381 0
lib80211_crypt_tkip 5674 2

lsmod shows these after connecting with frisbee, not before.
Probably this has to do with my WPA-TKIP security.
When booting without savefile and doing a modprobe on these modules first, frisbee connects fine also.
But I have the feeling the latter works in my case and might not work for everyone.
So maybe the sbin symlink and modprobe copying might be a more overall solution.

Hopefully someone with more knowledge than me will shine a light on this.

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Wireless problems workaround

Postby Marv » 23 Oct 2013, 22:00

Hi fredx,
I have a couple of ipw2200 wireless laptops. My solution for them has been to load the libcrypt module 'manually'. Also in my iwlwifi laptop I have been loading iwldvm. I'll pull those from the modules line in rc.conf and try your fix over the next couple of days and let you know results.
Edit:
You are batting 100% here :D :D :D On both the ipw2200 and the iwlwifi 5000 laptops, I applied your fix and stripped the modules line in /etc/rc.conf. First, I just rebooted and wireless connections survived reboot. Correct modules show up in a lsmod in both laptops. Then In each 'fixed' laptop, I deleted the wireless profile, rebooted, and connected perfectly in each case (WPA2 encryption). I'll try and think on the 'why' of it.

It does indeed seem a more general fix so far. More testers? John? Scooby? Smil99?

smil99
Proficient
Posts: 73
Joined: 14 Sep 2013, 13:37

Re: Wireless problems workaround

Postby smil99 » 23 Oct 2013, 23:34

Hi all,
Indeed, fredx's fix seems to solve the mystery. :) I even deleted the modprobe link and kmod found in /bin and then omitted iwldvm from the modprobe line in /etc/rc.conf. But then, creating sbin as a symlink to /usr/bin seems to negate simargl's approach of going without sbin among others, as per the new archlinux framework.
Cheers.

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Wireless problems workaround

Postby Marv » 24 Oct 2013, 04:19

Hi,

Snuffling around a bit more. Agreed, reinstating sbin isn't ideal, but this certainly is simple and a pointer in the right direction. On my iwlwifi laptop, just a symlink /sbin, linking to /bin seems to work without copying the files to /usr/bin. Does that work for you fredx or is the copy to and link to /usr/bin necessary? Don't see any sbin dependencies in frisbee. Maybe something in wpa_supplicant? Haven't tried the pure /sbin /bin link on my ipw2200 yet.

G'night mates

fredx
Apprentice
Posts: 7
Joined: 25 Sep 2013, 20:52

Re: Wireless problems workaround

Postby fredx » 24 Oct 2013, 10:34

Marv wrote:You are batting 100% here :D :D :D


Haha, good to hear!
Yes, just symlink /sbin pointing to /bin without copying modprobe works for me also.
As for reinstating sbin as symlink to /usr/bin: I thought the Arch Linux framework has that.(Also /bin -> /usr/bin, /usr/sbin -> /usr/bin and even /lib -> /usr/lib symlinks).
I experimented a little by installing the 'filesystem' package, first needed to copy all /bin to /usr/bin (no overwriting)
and all /lib to /usr/lib Then deleted /bin (first open terminal) and /lib and 'pacman -S filesystem --force'.
The symlinks will appear then; this is how I initialy found out how to make wireless working.

Good luck in solving the "mystery".
(I did e.g. 'grep -r sbin /etc/*' and 'grep -r sbin /lib/*' but couldn'd find anything useful)

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Wireless problems workaround

Postby Marv » 24 Oct 2013, 15:23

fredx wrote:Yes, just symlink /sbin pointing to /bin without copying modprobe works for me also.
As for reinstating sbin as symlink to /usr/bin: I thought the Arch Linux framework has that.(Also /bin -> /usr/bin, /usr/sbin -> /usr/bin and even /lib -> /usr/lib symlinks).

I don't know enough Arch to know but for now the symlink will reside happily in my systems.
And thanks!

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: Wireless problems workaround

Postby Scooby » 24 Oct 2013, 17:07

Marv wrote:It does indeed seem a more general fix so far. More testers? John? Scooby? Smil99?


Tried the fix on a iwlwifi laptop, erasing "iwldvm" from modules-line in rc.conf and symlinked /sbin to /bin.

Works!

Also when I built virtualbox I had the same problem and applied the same fix.

Seems like arch by default has this symlink.
.

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: Wireless problems workaround

Postby simargl » 25 Oct 2013, 08:16

---
Edit: Ignore this post.
---
I noticed that eudev has option

--with-modprobe=modprobe
specify location of modprobe when --[default=$sbindir/modprobe]

so I compiled eudev with option:
--with-modprobe="/bin/modprobe"

Let's see if that helps.

Download:
http://www1.datafilehost.com/d/9f74c92b


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests

cron