Touchpad in 11

Post your comments, questions, bug reports or suggest new features for alphaOS
Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Touchpad in 11

Postby Marv » 14 Sep 2013, 15:19

Touchpad is now working in 11 with tapping disabled, scrolling etc. The synaptics driver was not loading because libmtdev.so.1.0.0 and a symlink to it named libmtdev.so.1 were missing from /usr/lib. Copying those from 10 and using my 50-synaptics.conf file from 10 got it working. Both are attached below for experimentation. I know the conf file could be cleaned up some but works for now.
Attachments
Touchpad_11.tar.gz
(12.16 KiB) Downloaded 235 times

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: Touchpad in 11

Postby simargl » 14 Sep 2013, 21:15

mtdev package is required by xf86-input-synaptics and it was missing in this, and also in previous version, now I will add it.

smil99
Proficient
Posts: 73
Joined: 14 Sep 2013, 13:37

Re: Touchpad in 11

Postby smil99 » 15 Sep 2013, 00:40

Hi Marv,
Thanks for posting this. However, couldn't work quite well on my Gateway Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz machine. Although the touchpad mouse movements and scrolling work, connecting an external mouse freezes the cursor. Is(Are) there any line(s) to edit in the 50-synaptics.conf file to make it work?
Cheers.

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Touchpad in 11

Postby Marv » 15 Sep 2013, 02:26

Hi smil99,

Hadn't tried that at all. Just plugged a USB mouse into this laptop (Fujitsu s6520 core 2 duo ) and it doesn't change the touchpad operation at all, nor does the mouse work at all. Just dead. I'll think on it and try it in another OS where I use the same conf file and one where the conf file is different. I'll let you know if I come up with anything. I assume that running without synaptics and the conf file the mouse worked correctly?

Marv

smil99
Proficient
Posts: 73
Joined: 14 Sep 2013, 13:37

Re: Touchpad in 11

Postby smil99 » 15 Sep 2013, 03:23

Marv wrote:
I assume that running without synaptics and the conf file the mouse worked correctly?

Yes, the USB mouse works after removing 50-synaptics.conf.
Cheers.

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Touchpad in 11

Postby Marv » 15 Sep 2013, 03:42

Hi again smil99,

Try the following in 11:
Back up your save file if you use one.
Delete or rename the 50-synaptics.conf file in /usr/share/X11/xorg.conf.d to something like 50-synaptics.conf_save to deactivate it.
in /etc/X11/xorg.conf, in line 2 change Option "AutoAddDevices" "false" to Option "AutoAddDevices" "true"

restart X (log out in the alphaOS stock menu).

Check that Synaptics is running by running synclient in the terminal. If so, it can be used to disable tapping etc. note: no spaces on either side of = in commands.
synclient MaxTapTime=0
synclient VertTwoFingerScroll=0
synclient VertEdgeScroll=1

flsynclient also could be installed for GUI control.

I currently have both touchpad under synaptics and a plugged in usb mouse working and no observable side effects so far. Have some other conf tricks to try but another test would be nice.

Let me know or ask if anything isn't clear.

Marv

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: Touchpad in 11

Postby simargl » 15 Sep 2013, 08:47

I added those lines in /etc/X11/xorg.conf because without them mouse and keyboard were locked in older versions with udev-175. Now, I changed "AutoAddDevices" "false" to "AutoAddDevices" "true", and it works, then I removed /etc/X11/xorg.conf completely, everything still works so that file is not longer required with upgraded eudev-205. So, why not remove it?

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Touchpad in 11

Postby Marv » 15 Sep 2013, 12:45

Thats where I'm headed. I think letting eudev take care of adding devices is the correct approach. Just being cautious and some more testing on different machines would be good. I have removed it and the core 2 duo seems fine. Your desktop? seems fine. I'll test it on my Pentium M laptops today and look at the Xorg logs and I assume smil99 will try it on his gateway. If all is ok, remove it and enable the "AutoAddDevices".

Edit: Seems just fine on the Pentium M laptops with ALPS touchpads. To make touchpad options changes persist, either flsynclient could be used (don't see it with pacman, maybe in AUR?) or options can be added to /etc/X11/xorg.d/50-synaptics.conf following line 13.
I have disabled tapping and added HorizEdgeScroll for these laptops there and they persist through X restart and reboot.

So far so good for removal of /usr/share/X11/xorg.conf.d/50-synaptics.conf on this end. I may try a pristine frugal on my ancient Athlon box in the cellar for laughs.

Posting from (and listening to Simple Radio) on the cellar box. About as far from the laptops as I can get! Athlon XP/MP 1.6GHx overclocked, Via 8237 audio, Via VT6102 ethernet (Rhine ii), Nvidia NV5 Riva TNT2 M64 Pro video driving a 1024x768 LCD, usb mouse, and a mighty 512 Mb RAM. Frugal Grub4Dos (In pupstate 13 yet!) install to an ancient 20Gb HDD. Used the savefile from the laptops upstairs which has all my panel and spacefm config and expected zip. And it booted, recognized all the hardware, has my full panel and spacefm plugins, and seems to have no trouble at all with the proposed conf file changes above.

One tough pup :D :D :D

The attached flsynclient runs in alphaOS 11. For manual install to /usr/bin. Put

Code: Select all

flsynclient -s
in /root/.start.sh to load the saved touchpad settings at boot or X restart. File /root/.flsynclient contains the settings. Best to keep the default edge settings if possible.
Attachments
flsynclient.tar.gz
(92.01 KiB) Downloaded 233 times

smil99
Proficient
Posts: 73
Joined: 14 Sep 2013, 13:37

Re: Touchpad in 11

Postby smil99 » 16 Sep 2013, 01:39

Marv wrote:
Delete or rename the 50-synaptics.conf file in /usr/share/X11/xorg.conf.d to something like 50-synaptics.conf_save to deactivate it.
in /etc/X11/xorg.conf, in line 2 change Option "AutoAddDevices" "false" to Option "AutoAddDevices" "true"
restart X (log out in the alphaOS stock menu).
Check that Synaptics is running by running synclient in the terminal. If so, it can be used to disable tapping etc. note: no spaces on either side of = in commands.
synclient MaxTapTime=0
synclient VertTwoFingerScroll=0
synclient VertEdgeScroll=1

Did all that and both USB mouse and touchpad under synaptics work ! :D
Cheers.

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: Touchpad in 11

Postby Marv » 16 Sep 2013, 01:46

smil99 wrote:Did all that and both USB mouse and touchpad under synaptics work ! :D
Cheers.

Great! That brings us up to 5 fairly different machines all behaving. Seems like it's pretty much a go for removal. More testing welcome of course.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests

cron