Anybody knows about hardware sensors

Post your comments, questions, bug reports or suggest new features for alphaOS
Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Anybody knows about hardware sensors

Postby Scooby » 08 Sep 2015, 19:43

*EDIT*

seems like Sim loaded this for his own machine see here:
viewtopic.php?f=4&t=3&p=3&hilit=sensors#p3

* added lm_sensors (hardware monitoring program) and service file which loads
needed module (smsc47b397 for my computer) on boot. For others it will be
different module, so you would need to run sensors-detect to find out what
is needed module and manually replace smsc47b397 in /etc/init.d/sensors.
sensors-detect is perl script so make sure devel module is loaded...


I will deactivate this for now.


==================================================
Hi all,

Anybody know what /etc/rc.d/sensors daemon is good for?

Code: Select all

#!/usr/bin/env bash
description="hardware sensors"
case $1 in
  start)
    modprobe smsc47b397 >/dev/null
    ;;
  stop)
    rmmod smsc47b397 >/dev/null
    ;;
esac



I have the module

Code: Select all

> file /usr/lib/modules/4.1.6-ALPHAOS/kernel/drivers/hwmon/smsc47b397.ko.xz
/usr/lib/modules/4.1.6-ALPHAOS/kernel/drivers/hwmon/smsc47b397.ko.xz: XZ compressed data


when I try it I only get

Code: Select all

> modprobe smsc47b397
modprobe: ERROR: could not insert 'smsc47b397': No such device


Seems like I do not have the correct hardware?


I am not sure what Sim tried to accomplish here?

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 4 guests

cron