14.1 for 64-bit only

Global announcements
meowcats
Competent
Posts: 23
Joined: 09 Sep 2013, 08:45

Re: 14.1 for 64-bit only

Postby meowcats » 25 Nov 2013, 05:54

simargl wrote:Can't find better fast and portable system, with pacman and bundles that is why.

Yes this is why I use alphaOS as well, however since it is portable i think you should take into consideration the vast amount of hardware that is not x86-64. What use of a portable system if you cannot use it amongst all common machines...

simargl wrote:In previous post, I meant on nvidia graphics card - had experience with those, once

here is example
Conflict between xorg-server-1.11 and nVidia legacy drivers


This is the worst example you could possibly find. It directly goes against what you say.
Nvidia dropped support for old cards and proprietary legacy driver is no longer compatible with current xorg. AMD/ATI has done the exact same and no longer support my HD4850 anymore.

Oh my; What possible solution could there be? Use the free drivers. The hardware is still supported, it was not depreciated in the kernel!
Even cards as old as Riva TNT have 3D support in nouveau.

smil99
Proficient
Posts: 73
Joined: 14 Sep 2013, 13:37

Re: 14.1 for 64-bit only

Postby smil99 » 25 Nov 2013, 07:40

john3voltas wrote:
Now the part of being x86_64 only is still very bad news

Sadly, this is the case for me as I have no 64-bit machine to test 14.1.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: 14.1 for 64-bit only

Postby Scooby » 25 Nov 2013, 12:22

john3voltas wrote:Between Frisbee and Pwireless2 I'd go with the latter.


In my opnion they are equal.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: 14.1 for 64-bit only

Postby Scooby » 26 Nov 2013, 00:00

smil99 wrote:john3voltas wrote:
Now the part of being x86_64 only is still very bad news

Sadly, this is the case for me as I have no 64-bit machine to test 14.1.


ALthough I can relate to your feelings about x86_64,
I can understand you since I wasnt able to run the OS
Sim created compiling from scratch (dont rember name or version twas the one with spkg
instead of pacman),

I absolutely love 64 bit system. Among the understandable critique I wanted to say

"Sim I really appreciate what you do!!"

john3voltas
Expert
Posts: 266
Joined: 19 May 2013, 21:53

Re: 14.1 for 64-bit only

Postby john3voltas » 26 Nov 2013, 02:05

Scooby wrote:"Sim I really appreciate what you do!!"

Same here, love his project. Just wish the project had more developers helping him.

labbe5
Competent
Posts: 20
Joined: 17 May 2013, 15:49

Re: 14.1 for 64-bit only

Postby labbe5 » 27 Nov 2013, 20:55

Hi Simargl,

You are still evolving.

I have a 64-bit computer, and a 32-bit laptop, and i still wonder what is all about 64-bit computers, except for the fact we can have more than 4g of ram. Nice for gamers, but not so useful for a casual user to play music, videos and DVDs.

Nevertheless, AlphaOS is your work, and a platform to experiment.

Please keep on this experiment. It's one of the very few OS which combine small iso, rock solid base, and limitless expandability.

Cheers!

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: 14.1 for 64-bit only

Postby simargl » 30 Nov 2013, 12:03

changes:
- home directory for user alpha is moved from /opt/home/alpha to /home/alpha
- deadbeef audio player replaced with audacious
- gwp replaced with wpset (wallpaper setter in vala)
- new package alphaos-tools will contain binaries from rootfs, to keep that clean from ARCH (CPU) specific files

nsunny
Posts: 1
Joined: 02 Jan 2014, 13:07

Re: 14.1 for 64-bit only

Postby nsunny » 02 Jan 2014, 13:14

simargl wrote:Version 14.0 has kernel 3.12.0 and is based on Arch packages from 2013/11/18. Starting from this release alphaOS is a 64-bit only operating system.


I really like the way AlphaOS has customized openbox such a way that it is useful. I usually can't use use openbox distros for my tasks. I also like the app collection and how it works overall. I like to keep it installed on my pendrive. But I have a notebook which doesn't support x86_64. It is i686. I can't use it on that. So I can't fully rely on the new version. :oops: I believe there are other many devices out there which doesn't support 64 bit. Please maintain a 32 bit version.


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 4 guests

cron