alphaOS 7.0

Global announcements
simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

alphaOS 7.0

Postby simargl » 21 May 2013, 11:27

Version 7.0 has been released as first alphaOS version based on Arch packages,
with pacman and its GUI fronted pacmanXG pre-installed, perfectly compatible.
Now this OS can be regarded as continuation of the ArchPup project.
Other changes: kernel was upgraded to version 3.9.1, fixed Simple Radio pop-up
notifications for continuous monitoring, made custom repository on google code...

Downloads
http://sourceforge.net/projects/alphaos/files

Ramesh Iyer
Apprentice
Posts: 6
Joined: 18 May 2013, 16:13

Re: alphaOS 7.0

Postby Ramesh Iyer » 21 May 2013, 12:19

main ISO file is not found. Hope uploading is progressing?

john3voltas
Expert
Posts: 266
Joined: 19 May 2013, 21:53

Re: alphaOS 7.0

Postby john3voltas » 21 May 2013, 22:09

simargl, don't take me wrong but I think all new announcements regarding new alphaOS releases should have a link to the sourceforge folder. Every new alphaOS release I get 2 or 3 emails from friends asking where they can download it...
Either that or you should make a phpbb section with no posting allowed just letting everybody know where the download link is.
I think I have already given you this advice before so don't be mad at me :P.
Cheers

Familyman
Posts: 1
Joined: 21 May 2013, 23:56

Re: alphaOS 7.0

Postby Familyman » 22 May 2013, 00:05

Hi simargl!

I have succeeded in installing alphaOS 7.0 without any major qualms.

While I like the ability to use PacmanXG to configure my system to my liking I found the compressed save file size is much larger than that of alphaOS 6.0 that had a lot more goodies installed. (I always zip my savefile for backup and reuse).

Hence I too would like to petition you to restore the repository of alphaOS 6.0 on another hosted Google Code site for those of us who like this simpler version.

Thanks in advance!


~Familyman~

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: alphaOS 7.0

Postby Marv » 22 May 2013, 01:08

Installed ok but I was not able to connect to the internet (intel ipw2200 firmware present and modprobed ok). Pwireless2 said wpa_cli wpa_supplicant and wpa_passphrase were missing. symlinks were in /usr/local/sbin but no files in /sbin. Copying them there from the 6.0 extras sfs got me on line normally.

Other than that seems fine. Haven't yet tackled the touchpad but my rude copy system gets me my printer, conky, and tint2 panels and usb mouse is fine.

Posting from 7.0, more later ;)

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: alphaOS 7.0

Postby simargl » 22 May 2013, 06:57

john3voltas wrote:... I think all new announcements regarding new alphaOS releases should have a link to the sourceforge folder.

OK, it is added. Thanks for reminding :)

@Familyman
New iso size is 103MB without locales and devel files for alpha.sfs 10MB+8MB (not for extra.sfs there is all included), without firefox 20MB and without gparted 5MB. Other than that this is perfect copy of version 6.0. With all of this things included size would be around 146MB, means that recompiling everything was saving 26MB. Compiling system from scratch is one thing, but maintaing is completely different, not very interesting :P and after no one wanted to join and help maintaing repository switching back to Arch base was only logical consecvence.

Marv,
you are right, wpa_cli and wpa_supplicant in Arch are now moved from /sbin to /usr/sbin, and those links from Pwireless are not correct anymore. Can you confirm that copying those original files from Arch to /sbin make Pwireless to work again, if yes I will fix it and upload iso again.

lvds
Apprentice
Posts: 6
Joined: 22 May 2013, 08:44

Re: alphaOS 7.0

Postby lvds » 22 May 2013, 11:58

simargl wrote:@Familyman
New iso size is 103MB without locales and devel files for alpha.sfs 10MB+8MB (not for extra.sfs there is all included), without firefox 20MB and without gparted 5MB. Other than that this is perfect copy of version 6.0. With all of this things included size would be around 146MB, means that recompiling everything was saving 26MB. Compiling system from scratch is one thing, but maintaing is completely different, not very interesting :P and after no one wanted to join and help maintaing repository switching back to Arch base was only logical consecvence.


Anyway most people already have a lot of work, or simply a real life to maintain, so it's much better to all work together and make stronger what we already have. When more people are using the arch repos, more people can send comments to upstream and contribute to distro improvements. Building new repos is not a good thing, see the weird situation now with puppy where users have hard time to find the software related to their puppy-release (most newbies simply don't understand).

simargl wrote:Marv,
you are right, wpa_cli and wpa_supplicant in Arch are now moved from /sbin to /usr/sbin, and those links from Pwireless are not correct anymore. Can you confirm that copying those original files from Arch to /sbin make Pwireless to work again, if yes I will fix it and upload iso again.


the sourceforge offer is large enough to let the 5 or more previous releases on line, just in case something went wrong... ;-)
Thanks

Marv
Proficient
Posts: 81
Joined: 16 May 2013, 16:42

Re: alphaOS 7.0

Postby Marv » 22 May 2013, 13:03

simargl wrote:
Marv,
you are right, wpa_cli and wpa_supplicant in Arch are now moved from /sbin to /usr/sbin, and those links from Pwireless are not correct anymore. Can you confirm that copying those original files from Arch to /sbin make Pwireless to work again, if yes I will fix it and upload iso again.


Originally I copied the wpa_* files from 6.0 to /sbin. That worked. Based on the above, I also tested with the wpa_ * files from /usr/sbin in 7.0, not those from 6.0 as they are probably compiled for the different kernels or different versions. Copying the files from /usr/sbin to /sbin in 7.0 did get Pwireless2 working. What about just fixing the symlinks in /usr/local/sbin to point to /usr/sbin where Arch now has those files?

simargl
Site Admin
Posts: 466
Joined: 16 May 2013, 10:54
Contact:

Re: alphaOS 7.0

Postby simargl » 22 May 2013, 13:28

Marv wrote:What about just fixing the symlinks in /usr/local/sbin to point to /usr/sbin where Arch now has those files?

That's the way I used, thanks Marv, new alphaOS_7.0-20130522.iso is uploaded http://sourceforge.net/projects/alphaos/files. :)

john3voltas
Expert
Posts: 266
Joined: 19 May 2013, 21:53

Re: alphaOS 7.0

Postby john3voltas » 22 May 2013, 15:59

simargl wrote:
Marv wrote:What about just fixing the symlinks in /usr/local/sbin to point to /usr/sbin where Arch now has those files?

That's the way I used, thanks Marv, new alphaOS_7.0-20130522.iso is uploaded http://sourceforge.net/projects/alphaos/files. :)

Great! I was also having trouble with my wifi connection.
Let's hope this fixes it.
BTW, remember my cpu temperature and fan always off in alphaOS 5.0? It seems it's fixed on alphaOS 7.0 :D.
I'll let you know more tonight.
Cheers

EDIT: Still having trouble with wifi. Pwireless2 does not show any networks. Marv seems to have found the same issue and he fixed it by restarting wpa_supplicant but it does not work in my case...
Last edited by john3voltas on 23 May 2013, 11:38, edited 1 time in total.


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest

cron