version 17.2

Global announcements
Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.2

Postby Scooby » 17 Nov 2015, 19:05

When I added vboxuser group and moved warning about pvs to debug messages I got
a really nice short log.

Code: Select all

[helpers] WARN: /sbin/blkid failed on /dev/sdc2, exit status 2
parent: all initial devices processed


sdc2 is a special partition entry used by easy2boot todo magic
with grub4dos via the partnew command so that is expected
and to be ignored

:D Easy to solve all errors on the developer's machine, eyyyy :ugeek:

pentajazz
Advanced
Posts: 48
Joined: 27 Apr 2014, 23:09

Re: version 17.2

Postby pentajazz » 21 Nov 2015, 12:15

I have tried a bit 17.2, on my notebook only mousepad is working, usb mouse is not responding. Conky seems grafically broken at the beginning. Altering settings resets it and then it is working again. Vdev, i do not know what this is, but it seems that it delays booting a bit comparing to 16.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.2

Postby Scooby » 21 Nov 2015, 13:03

pentajazz wrote:I have tried a bit 17.2, on my notebook

Hi pentajazz, good to see you again.

pentajazz wrote:only mousepad is working usb mouse is not responding.

That's really interesting, I have just been working on fixing USB mouse issue and thought it working.
I hope you want to help out

Questions:

1. You are sure you are on 17.2 and not on 17.1?
This is really important. There are a lot of indications you are still on 17.1
Do you perhaps have a savefile from 17.1?

2. Check output of cat /etc/vdev/actions/input.act and see if there is a line saying daemonlet=true
It should not be there

3. paste output of command "tree /dev/input"

4. What kind of USB mouse do you have, very old or very new?
It was working on 16?

5. send me

Code: Select all

/var/log/vdev/vdevd.log 
/var/log/Xorg.0.log
/tmp/session-0.log
/tmp/udev-compat.log
/tmp/boot.log


pentajazz wrote: Conky seems grafically broken at the beginning. Altering settings resets it and then it is working again.

This was the problem from 17.1. I downgraded conky in 17.2 and at least for me I don't see this problem anymore.
plz paste output of conky --version

pentajazz wrote: Vdev, i do not know what this is, but it seems that it delays booting a bit comparing to 16.


vdev is a replacement for udev.
They are used for device management( stuff in /dev and hotplugg)

It is my belief that systemd-politricks will make udev impossible to use
without systemd it self.

vdev is still in development and there should be ways to speed it up.
For now you are of course correct, vdev is considerable slower than udev.

I wonder what time to desktop is in comparison between 16 and 17.
I remember 16 had the AUFS bug that delayed "remounting rootfs..." quite a bit.

pentajazz
Advanced
Posts: 48
Joined: 27 Apr 2014, 23:09

Re: version 17.2

Postby pentajazz » 21 Nov 2015, 19:46

Scooby wrote:
pentajazz wrote:I have tried a bit 17.2, on my notebook

This was the problem from 17.1


You are absolutely right, I have mixed 17.1 with 17.2 by mistake. Thanks for pointing this out and sorry for the frustration. Everything is working now, I will test further and report back if I will find something interesting.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.2

Postby Scooby » 23 Nov 2015, 18:57

Sounds good man.

Any feedback is good feedback

pentajazz
Advanced
Posts: 48
Joined: 27 Apr 2014, 23:09

Re: version 17.2

Postby pentajazz » 24 Nov 2015, 23:53

Considering vdev I would like to inform you about manjaro openrc version (Systemd free version), as it is one of the distros i often use. Check this out if you want:
https://forum.manjaro.org/index.php?topic=26749.0

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.2

Postby Scooby » 25 Nov 2015, 19:16

pentajazz wrote:manjaro openrc version (Systemd free version)
...
Check this out if you want:


Interesting

From the thread you gave I gather there still is a libsystemd dependency, right?

efgee
Expert
Posts: 115
Joined: 29 Dec 2013, 20:58

Re: version 17.2

Postby efgee » 25 Nov 2015, 20:56

Hello Scooby,
finally had some time to play with alphaos.
Got this version on a usb stick and booted from it.

PeasyWifi doesn't work for me at all.
The configuration files are never written, therefore I can never choose the "created" profile and get access to my router.
The older alphaos versions came with conman and it was a breeze to use, for me it worked 100% of the time.

Also clicking around on the right icons on tint2 resulted in the app icon (far left) to not react anymore.

Here something that I observed: the icons in the dlauncher app have not the same size.
It becomes very prevalent when the Qt libs are installed and 4 Qt icons appear in dlauncher.

To avoid that, simply change this code in dlauncher/src/model.vala:

Code: Select all

            try
            {
                pix = icon_theme.load_icon(icon, 64, 0); // from icon theme
            }
            catch (GLib.Error e)
            {
                try
                {
                    pix = icon_theme.load_icon("application-x-executable", 64, 0); // fallback
                }
                catch (GLib.Error e)
                {
                    stderr.printf ("%s\n", e.message);
                }
            }
 

to:

Code: Select all

            try
            {
                pix = icon_theme.load_icon(icon, 64, Gtk.IconLookupFlags.FORCE_SIZE); // from icon theme
            }
            catch (GLib.Error e)
            {
                try
                {
                    pix = icon_theme.load_icon("application-x-executable", 64, Gtk.IconLookupFlags.FORCE_SIZE); // fallback
                }
                catch (GLib.Error e)
                {
                    stderr.printf ("%s\n", e.message);
                }
            }
 


Don't know why when the icon size is set GTK only tries to set the size instead of just doing it.
The "Gtk.IconLookupFlags.FORCE_SIZE" flag (instead of 0) fixes this.

Talk to you later.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.2

Postby Scooby » 26 Nov 2015, 18:36

efgee wrote:PeasyWifi doesn't work for me at all.
The configuration files are never written, therefore I can never choose the "created" profile and get access to my router.
The older alphaos versions came with conman and it was a breeze to use, for me it worked 100% of the time.

I kind of got that you were in favor of connman.
I however did have many problems with it.

I like peasywifi and think we can get it to work properly
I would need a little more info from you though,
could you run it from a console window and post output?

I just tried it here and it works.

peasywifi is scheduled for a full overhaul I had other problems to deal with though.

Anyway should be easy to convert back to connman if that is more to your liking.
I will help of course.


efgee wrote:Also clicking around on the right icons on tint2 resulted in the app icon (far left) to not react anymore.

I cannot reproduce

probably tint2 crashed. You could check logs if there is anythingin there.
Test if killall tint2; tint2 & will fix it

efgee wrote:Here something that I observed: the icons in the dlauncher app have not the same size.
It becomes very prevalent when the Qt libs are installed and 4 Qt icons appear in dlauncher.

To avoid that, simply change this code in dlauncher/src/model.vala:

ok, you did try it and it works?

*EDIT*
I tried it and yes I think that looks a little better.
Definitely will go into next version.

Could you report this to simargl at https://github.com/simargl/vala-apps ?
Could be good to have sim incorporate it "upstream"

pentajazz
Advanced
Posts: 48
Joined: 27 Apr 2014, 23:09

Re: version 17.2

Postby pentajazz » 27 Nov 2015, 14:19

PeasyWifi doesn't work for me also. It cannot write its config files. It is though finds the wifi and detects broadcasted signals. It cannot connect to them.


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 2 guests

cron