version 17.1

Global announcements
Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 03 Nov 2015, 19:44

obarun wrote:see my last post on nelson github. module cause trouble, try to load your mouse module earlier(before vdev). Modalias fonction seem to not work properly, i try to find the trouble but for the moment....


I saw it.

We do not have the same issue, man.

I have correct /dev/input/{by-id,by-path}
in fact everything in /dev seems to be on par with what I get with udev.

My problem lies when vdevd signals to libudev and listeners what's going on.

I can get it to work with a single "sleep 1s" if I like

In initramsfs I let busybox-->mdev handle things, mouse modules get loaded automatically by evdev
when alphaOS switch to vdev.

Or are we not talking about the same thing?

wyzguy
Apprentice
Posts: 13
Joined: 07 Oct 2015, 07:09

Re: version 17.1

Postby wyzguy » 04 Nov 2015, 00:56

Scooby,

Please google for: "the current busybox or my code seems to be broken" (with the quotes)

They talk about "mdev" and it is current (March 2015 ).

There are only 5 hits for this google search.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 05 Nov 2015, 09:12

well it works for alphaos needs in initram so I will not put in time
researching this, sorry


mdev does its job for alphaos initram.
then vdev takes over and it needs a bit of polishing but we should be good

*EDIT*
OK

couldn't help myself so I checked your links, nothing new to me
since I am on that mailing-list

obarun
Advanced
Posts: 42
Joined: 13 Oct 2015, 07:45

Re: version 17.1

Postby obarun » 07 Nov 2015, 17:26

hi :)

here you can find changement about dev-setup.sh. i don't make a pull request for the moment but if you want to try. i have now the correct devpath definitions on preseed.
So i found a big trouble with modprobe.sh ( please see commit). the OS_MODALIAS is not the good name, so modprobe can load modules (normal). for the moment i don't found solution, but one thing puzzle me on the file sd-hwdb.c. i don't understand exactly for the moment but it seem be supicious

Code: Select all

static const char hwdb_bin_paths[] =
    "/etc/systemd/hwdb/hwdb.bin\0"
    "/etc/udev/hwdb.bin\0"
    "/usr/lib/systemd/hwdb/hwdb.bin\0"

So with a working around about modprobe trouble, i have now mouse keyboard hotplug fully functionnal on X server. hook too (not updated on my repo)

EDIT: issue open
https://github.com/jcnelson/vdev/issues/79

RE EDIT lol:
eudev-libgudev was splitted. you can find ligudev-nosystemd if you want on my repo

Edit: people are very difficult! i mean, people don't do thing with reflection and ask for all and nothing, they don't learn nothing and ask after : "why doesn't work?". Well very difficult :(

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 07 Nov 2015, 22:52

obarun wrote:here you can find changement about dev-setup.sh. i don't make a pull request for the moment but if you want to try. i have now the correct devpath definitions on preseed.

I took the original and your version of dev-setup.sh and added debug echo's as can be seen here https://gist.github.com/suedi/6fd912dc0d418b96963e
removed all else that is not needed for feed_static_nodes_kmod() so I can test.

Okay some further testing I think I get what you mean

Exampel

with jcnelson's version: c snd/seq 116 1 SUBSYSTEM=sound

with obarun's version: c snd_seq 116 1

Do you mean that then modprobe snd/seq fails?

If so, your change of dev-setup.sh is rather drastic
could you not just replace / with _ in name?

yielding at line number 184-185

Code: Select all

   # this is extra replacing / with _ in name
  name="$(echo $name | sed 's/\//_/')"
  # feed into vdevd via stdout
    echo "$type $name $major $minor $param


That may not be a good solution due to naming conventions
Ex: vfio vfio/vfio c10:196

this is my try of re-write of that function

https://gist.github.com/suedi/cd629567da653de45807


Also your version breaks guess_subsystem()
that have

Code: Select all

if [ "$devname" = "snd/seq" ]; then
      echo "sound"
   fi

Could be easily fixed though :D


obarun wrote:So i found a big trouble with modprobe.sh ( please see commit). the OS_MODALIAS is not the good name, so modprobe can load modules (normal).

I only saw you added log for debugging, I could test that if you like?

Why is it not a good name do you think?

obarun wrote:for the moment i don't found solution, but one thing puzzle me on the file sd-hwdb.c. i don't understand exactly for the moment but it seem be supicious

Code: Select all

static const char hwdb_bin_paths[] =
    "/etc/systemd/hwdb/hwdb.bin\0"
    "/etc/udev/hwdb.bin\0"
    "/usr/lib/systemd/hwdb/hwdb.bin\0"



The commit message for that file is " Make libudev-compat ABI-compatible with libudev"
So I guess it is to "appear" ABI-compatible with libudev, right?

you don't have those files on your system, do you?

obarun wrote:So with a working around about modprobe trouble, i have now mouse keyboard hotplug fully functionnal on X server. hook too (not updated on my repo)

Good job

obarun
Advanced
Posts: 42
Joined: 13 Oct 2015, 07:45

Re: version 17.1

Postby obarun » 08 Nov 2015, 00:53

First, thank you so much for the lesson :). i adopt it.
Do you mean that then modprobe snd/seq fails?

yes
If so, your change of dev-setup.sh is rather drastic

i think too, but loading modules as earlier as possible seem to be an idea.(good or not?). I don't understand all the architecture of vdev, but dev-setup.sh is called after modalias.act or before? if it is after, modalias.act don't get modules for static_nodes and so modules is not loaded, right or wrong?the reverse can be equal, i think.
could you not just replace / with _ in name?

i have thought it, but as you can see some modules cause trouble with Ex: vfio vfio/vfio c10:196 . i will test your version.

Also your version breaks guess_subsystem()
that have

Code: Select all
if [ "$devname" = "snd/seq" ]; then
echo "sound"
fi

Could be easily fixed though :D


wow, thank for that, i don't see it. yes this is a good lesson too :).

I only saw you added log for debugging, I could test that if you like?


Starting vdev on primary hook have a trouble when loading modules. I don't understand all the architecture of vdev(again lol), however 002-modalias.act call modprobe.sh for load the modules. here is my output (sorry for implement it here, i need to learn how to make it as you on github).

these are logs of modprobe.sh

note : this is the first one before remake hwdb.squashfs


Code: Select all

modprobe: FATAL: Module dmi:bvnAmericanMegatrendsInc.:bvrF5:bd08/13/2014:svnGIGABYTE:pnMSH81TN-00:pvr1.x:rvnGIGABYTE:rnMSH81TN-00:rvr1.x:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.: not found.
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: FATAL: Module platform:vesa-framebuffer not found.
modprobe: FATAL: Module platform:serial8250 not found.
modprobe: FATAL: Module platform:regulatory not found.
modprobe: FATAL: Module platform:microcode not found.
modprobe: FATAL: Module platform:e820_pmem not found.
modprobe: FATAL: Module platform:coretemp not found.
modprobe: FATAL: Module platform:alarmtimer not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module pci:v00008086d00000C00sv00001458sd00005000bc06sc00i00 not found.
modprobe: FATAL: Module acpi:LNXSYSTM: not found.
modprobe: FATAL: Module acpi:SKTD000: not found.
modprobe: FATAL: Module acpi:NXP5442: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:PNP0A08:PNP0A03: not found.
modprobe: FATAL: Module acpi:PNP0C09: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0B00: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0200: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:PNP0100: not found.
modprobe: FATAL: Module acpi:PNP0000: not found.
modprobe: FATAL: Module acpi:INT3F0D:PNP0C02: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:ABCD0000:PNP0C15: not found.
modprobe: FATAL: Module acpi:INT3420: not found.
modprobe: FATAL: Module acpi:INT33D4:PNP0C70: not found.
modprobe: FATAL: Module acpi:INT33D3:PNP0C60: not found.
modprobe: FATAL: Module acpi:INT33D2:PNP0C40: not found.
modprobe: FATAL: Module acpi:INT33A1:PNP0D80: not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: FATAL: Module acpi:ICV0A12: not found.
modprobe: FATAL: Module dmi:bvnAmericanMegatrendsInc.:bvrF5:bd08/13/2014:svnGIGABYTE:pnMSH81TN-00:pvr1.x:rvnGIGABYTE:rnMSH81TN-00:rvr1.x:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.: not found.
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
modprobe: FATAL: Module platform:vesa-framebuffer not found.
modprobe: FATAL: Module platform:serial8250 not found.
modprobe: FATAL: Module platform:regulatory not found.
modprobe: FATAL: Module platform:microcode not found.
modprobe: FATAL: Module platform:e820_pmem not found.
modprobe: FATAL: Module platform:coretemp not found.
modprobe: FATAL: Module platform:alarmtimer not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module pci:v00008086d00000C00sv00001458sd00005000bc06sc00i00 not found.
modprobe: FATAL: Module acpi:LNXSYSTM: not found.
modprobe: FATAL: Module acpi:SKTD000: not found.
modprobe: FATAL: Module acpi:NXP5442: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:PNP0A08:PNP0A03: not found.
modprobe: FATAL: Module acpi:PNP0C09: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0B00: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0200: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:PNP0100: not found.
modprobe: FATAL: Module acpi:PNP0000: not found.
modprobe: FATAL: Module acpi:INT3F0D:PNP0C02: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:ABCD0000:PNP0C15: not found.
modprobe: FATAL: Module acpi:INT3420: not found.
modprobe: FATAL: Module acpi:INT33D4:PNP0C70: not found.
modprobe: FATAL: Module acpi:INT33D3:PNP0C60: not found.
modprobe: FATAL: Module acpi:INT33D2:PNP0C40: not found.
modprobe: FATAL: Module acpi:INT33A1:PNP0D80: not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: FATAL: Module acpi:ICV0A12: not found.


note : and the second after remake hwdb.squashfs

Code: Select all

modprobe: FATAL: Module dmi:bvnAmericanMegatrendsInc.:bvrF5:bd08/13/2014:svnGIGABYTE:pnMSH81TN-00:pvr1.x:rvnGIGABYTE:rnMSH81TN-00:rvr1.x:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.: not found.
modprobe: FATAL: Module platform:vesa-framebuffer not found.
modprobe: FATAL: Module platform:serial8250 not found.
modprobe: FATAL: Module platform:regulatory not found.
modprobe: FATAL: Module platform:microcode not found.
modprobe: FATAL: Module platform:e820_pmem not found.
modprobe: FATAL: Module platform:coretemp not found.
modprobe: FATAL: Module platform:alarmtimer not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module pci:v00008086d00000C00sv00001458sd00005000bc06sc00i00 not found.
modprobe: FATAL: Module acpi:LNXSYSTM: not found.
modprobe: FATAL: Module acpi:SKTD000: not found.
modprobe: FATAL: Module acpi:NXP5442: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXPOWER: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:PNP0A08:PNP0A03: not found.
modprobe: FATAL: Module acpi:PNP0C09: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0B00: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0501: not found.
modprobe: FATAL: Module acpi:PNP0200: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:PNP0100: not found.
modprobe: FATAL: Module acpi:PNP0000: not found.
modprobe: FATAL: Module acpi:INT3F0D:PNP0C02: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:ABCD0000:PNP0C15: not found.
modprobe: FATAL: Module acpi:INT3420: not found.
modprobe: FATAL: Module acpi:INT33D4:PNP0C70: not found.
modprobe: FATAL: Module acpi:INT33D3:PNP0C60: not found.
modprobe: FATAL: Module acpi:INT33D2:PNP0C40: not found.
modprobe: FATAL: Module acpi:INT33A1:PNP0D80: not found.
modprobe: FATAL: Module acpi:INT33A0: not found.
modprobe: FATAL: Module acpi:ICV0A12: not found.


So i have a difference isn't it?this issue puzzle me. but is not the subject. As you can see something wrong. Vdev should loaded all the necessary modules and i think is not the case :).

The commit message for that file is " Make libudev-compat ABI-compatible with libudev"
So I guess it is to "appear" ABI-compatible with libudev, right?


yes. Sure, compatibility with systemd ok no problem but systemd needed...

you don't have those files on your system, do you?


god bless you my friend :). not i don't have :).

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 08 Nov 2015, 15:08

obarun wrote:i think too, but loading modules as earlier as possible seem to be an idea.(good or not?). I don't understand all the architecture of vdev, but dev-setup.sh is called after modalias.act or before? if it is after, modalias.act don't get modules for static_nodes and so modules is not loaded, right or wrong?the reverse can be equal, i think.

dev-setup.sh is called before modalias.act(modprobe.sh), check vdevd/main.c


obarun wrote:Starting vdev on primary hook have a trouble when loading modules. I don't understand all the architecture of vdev(again lol), however 002-modalias.act call modprobe.sh for load the modules.


I am not either a 100% familiar with vdev architeture. I am used to object oriented language like c++
so have a difficult time following flow in vdevd c-files

yes 002-modalias.act call modprobe.sh, true.

obarun wrote:here is my output (sorry for implement it here, i need to learn how to make it as you on github).

Just as correct as on github, those are called gist's
check https://gist.github.com/ when signed in on github

obarun wrote:these are logs of modprobe.sh

Had a quick check, fairly similar but not a 100%, right?

seems the first log, before hwdb fix. There is vdev run twice. right?
because there are a lot of duplicates

if you take away that then diff is only these two line that is
only present in first log

Code: Select all

modprobe: ERROR: could not insert 'ghash_clmulni_intel': Invalid argument
... # repeated 4 times on lines 2-5
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
... # repeated 8 times  on lines 130-137



I will test with logging here and post results

obarun wrote:So i have a difference isn't it?this issue puzzle me. but is not the subject. As you can see something wrong. Vdev should loaded all the necessary modules and i think is not the case :).

I really don't know.
udev does this for you then?


obarun wrote:god bless you my friend :).

god bless

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 08 Nov 2015, 15:35

tried with new dev-setup.sh version and only diff with lsmod
was ipv6 was loaded after update

also something messed up with new code since I get in /dev

tried with modprobe logging, I get devices

Code: Select all

/dev/snd_seq
/dev/snd_timer


so the code for feed_static_kmod_nodes is not correct, I think it needs /snd/seq here

Code: Select all

modprobe: FATAL: Module dmi:bvnAmericanMegatrendsInc.:bvrK73SV.210:bd11/16/2011:svnASUSTeKComputerInc.:pnK73SV:pvr1.0:rvnASUSTeKComputerInc.:rnK73SV:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0: not found.
modprobe: FATAL: Module platform:serial8250 not found.
modprobe: FATAL: Module platform:reg-dummy not found.
modprobe: FATAL: Module platform:platform-framebuffer not found.
modprobe: FATAL: Module platform:i8042 not found.
modprobe: FATAL: Module platform:alarmtimer not found.
modprobe: FATAL: Module pci:v00008086d00001C03sv00001043sd00001237bc01sc06i01 not found.
modprobe: FATAL: Module scsi:t-0x05 not found.
modprobe: FATAL: Module scsi:t-0x00 not found.
modprobe: FATAL: Module scsi:t-0x00 not found.
modprobe: FATAL: Module acpi:PNP0C09: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module pci:v00008086d00001C26sv00001043sd00001237bc0Csc03i20 not found.
modprobe: FATAL: Module usb:v8087p0024d0000dc09dsc00dp01ic09isc00ip00in00 not found.
modprobe: FATAL: Module usb:v8564p1000d1100dc00dsc00dp00ic08isc06ip50in00 not found.
modprobe: FATAL: Module scsi:t-0x00 not found.
modprobe: FATAL: Module usb:v1D6Bp0002d0401dc09dsc00dp00ic09isc00ip00in00 not found.
modprobe: FATAL: Module pci:v00008086d00001C2Dsv00001043sd00001237bc0Csc03i20 not found.
modprobe: FATAL: Module usb:v8087p0024d0000dc09dsc00dp01ic09isc00ip00in00 not found.
modprobe: FATAL: Module usb:v058FpA014d0003dcEFdsc02dp01ic0Eisc02ip00in01 not found.
modprobe: FATAL: Module usb:v1D6Bp0002d0401dc09dsc00dp00ic09isc00ip00in00 not found.
modprobe: FATAL: Module pci:v00008086d00001C3Asv00001043sd00001237bc07sc80i00 not found.
modprobe: FATAL: Module pci:v00008086d00000104sv00001043sd00001237bc06sc00i00 not found.
modprobe: FATAL: Module acpi:LNXSYSTM: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:LNXSYBUS: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C0F: not found.
modprobe: FATAL: Module acpi:PNP0C01: not found.
modprobe: FATAL: Module acpi:PNP0A08:PNP0A03: not found.
modprobe: FATAL: Module acpi:PNP0C09: not found.
modprobe: FATAL: Module acpi:PNP0C04: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0B00: not found.
modprobe: FATAL: Module acpi:PNP0303:PNP030B: not found.
modprobe: FATAL: Module acpi:PNP0200: not found.
modprobe: FATAL: Module acpi:PNP0103: not found.
modprobe: FATAL: Module acpi:PNP0100: not found.
modprobe: FATAL: Module acpi:PNP0000: not found.
modprobe: FATAL: Module acpi:INT3F0D:PNP0C02: not found.
modprobe: FATAL: Module acpi:INT0800: not found.
modprobe: FATAL: Module acpi:ETD0101:PNP0F0E:PNP0F03:PNP0F12:PNP0F0B:PNP0F13: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:PNP0C02: not found.
modprobe: FATAL: Module acpi:INT340E:PNP0C02: not found.
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: ERROR: could not insert 'pcc_cpufreq': No such device
modprobe: FATAL: Module platform:microcode not found.
modprobe: FATAL: Module platform:coretemp not found.
modprobe: FATAL: Module wmi:921A2F40-0DC4-402D-AC18-B48444EF9ED2 not found.
modprobe: FATAL: Module wmi:C12AD361-9FA9-4C74-901F-95CB0945CF3E not found.
modprobe: FATAL: Module wmi:EF4F3564-48C8-4894-85C8-B46C26B842C0 not found.
modprobe: FATAL: Module wmi:42848006-8886-490E-8C72-2BDCA93A8A09 not found.
modprobe: FATAL: Module wmi:E06BDE62-EE75-48F4-A583-B23E69ABF891 not found.
modprobe: FATAL: Module wmi:3ADEBD0F-0C5F-46ED-AB2E-04962B4FDCBC not found.
modprobe: FATAL: Module wmi:05901221-D566-11D1-B2F0-00A0C9062910 not found.
modprobe: FATAL: Module wmi:97845ED0-4E6D-11DE-8A39-0800200C9A66 not found.
modprobe: FATAL: Module platform:regulatory not found.
modprobe: FATAL: Module platform:asus-nb-wmi not found.

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 09 Nov 2015, 20:43

I have created a new version of alphaos with fixes.

Will run a few days then release as 17.2 if nothing bad happens

efgee
Expert
Posts: 115
Joined: 29 Dec 2013, 20:58

Re: version 17.1

Postby efgee » 09 Nov 2015, 22:48

Looking forward to it :)

Thank you for your hard work...


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 5 guests

cron