version 17.1

Global announcements
efgee
Expert
Posts: 115
Joined: 29 Dec 2013, 20:58

Re: version 17.1

Postby efgee » 23 Sep 2015, 21:54

Scooby,
you did a tremendous job coming that far on your own.
Congratulation :!:

Got the ISO onto a USB stick and ran it.
vdev took a long time to finish but after that the system was very responsive.

Creating software bundles is a breeze, awesome.
Started creating several software bundles:
cups, firefox, gparted, hplip, htop, jre, libreoffice, terminator, thunar, etc.

One thing that I would like to see is to be able to get all applications as software bundles and be able to switch them on/off when I need/want it.
The best would be (I'm dreaming here...) if the main menu would show the software bundles and on clicking them they get activated and the app started. (suppose a config file would be needed with info like: software bundle dependency, name of app to start, etc.)

So I removed evince and got it back (makesb evince) as bundle, however it's not working...
Maybe the installed version was an older one with less dependencies.
(same with termite, deadbeef...)
What about Voyager, GMPVideo, PlayTV, SimpleRadio how do I get rid of them?

Want to do the same with all the other (no-system) apps but it's not as easy, as they might not be installed via the package manager.
Example: Geany does not show up with "pacman -Ss geany".

Anyhow, alphaOS is still a very good small distro that I want to use in the future.
Keep up the excellent job.


BTW: what is the init system? openrc/runit/sinit?

Take care

ncmprhnsbl
Competent
Posts: 36
Joined: 09 Nov 2013, 22:44

Re: version 17.1

Postby ncmprhnsbl » 24 Sep 2015, 04:32

hi efgee, for package names, check var/lib/pacman/local , some are git versions built gtk3

@Scooby
re vdev
here are the logs for comparison, if you get a usb mouse ... need a new one meself..
vdev log: https://www.dropbox.com/s/5dmr25expe7n7 ... d.log?dl=0
libudev-compat log >> http://pastebin.com/sDdPBjiS
note this below is with serial mouse, tho the wacom pentablet is there

Code: Select all

root@alphaos ~]# ls -l -R /dev/input/
/dev/input/:
total 0
drwxr-xr-x 2 root root    120 Sep 24  2015 by-id
drwxr-xr-x 2 root root    200 Sep 24  2015 by-path
crw------- 1 root root 13, 64 Sep 24  2015 event0
crw------- 1 root root 13, 65 Sep 24  2015 event1
crw------- 1 root root 13, 74 Sep 24  2015 event10
crw------- 1 root root 13, 75 Sep 24  2015 event11
crw------- 1 root root 13, 76 Sep 24  2015 event12
crw------- 1 root root 13, 77 Sep 24  2015 event13
crw------- 1 root root 13, 78 Sep 24  2015 event14
crw------- 1 root root 13, 79 Sep 24  2015 event15
crw------- 1 root root 13, 80 Sep 24  2015 event16
crw------- 1 root root 13, 81 Sep 24  2015 event17
crw------- 1 root root 13, 66 Sep 24  2015 event2
crw------- 1 root root 13, 67 Sep 24  2015 event3
crw------- 1 root root 13, 68 Sep 24  2015 event4
crw------- 1 root root 13, 69 Sep 24  2015 event5
crw------- 1 root root 13, 70 Sep 24  2015 event6
crw------- 1 root root 13, 71 Sep 24  2015 event7
crw------- 1 root root 13, 72 Sep 24  2015 event8
crw------- 1 root root 13, 73 Sep 24  2015 event9
crw------- 1 root root 13,  0 Sep 24  2015 js0
crw------- 1 root root 13, 63 Sep 24  2015 mice
crw------- 1 root root 13, 32 Sep 24  2015 mouse0
crw------- 1 root root 13, 33 Sep 24  2015 mouse1
crw------- 1 root root 13, 34 Sep 24  2015 mouse2

/dev/input/by-id:
total 0
lrwxrwxrwx 1 root root 19 Sep 24  2015 usb-Wacom_Co._Ltd._Intuos5_touch_S-event-mouse -> ../../input/event15
lrwxrwxrwx 1 root root 19 Sep 24  2015 usb-Wacom_Co._Ltd._Intuos5_touch_S-if01-event-mouse -> ../../input/event17
lrwxrwxrwx 1 root root 18 Sep 24  2015 usb-Wacom_Co._Ltd._Intuos5_touch_S-if01-mouse -> ../../input/mouse2
lrwxrwxrwx 1 root root 18 Sep 24  2015 usb-Wacom_Co._Ltd._Intuos5_touch_S-mouse -> ../../input/mouse1

/dev/input/by-path:
total 0
lrwxrwxrwx 1 root root 19 Sep 24  2015 pci-0000:00:12.0-usb-0:3:1.0-event-mouse -> ../../input/event15
lrwxrwxrwx 1 root root 18 Sep 24  2015 pci-0000:00:12.0-usb-0:3:1.0-mouse -> ../../input/mouse1
lrwxrwxrwx 1 root root 19 Sep 24  2015 pci-0000:00:12.0-usb-0:3:1.1-event-mouse -> ../../input/event17
lrwxrwxrwx 1 root root 18 Sep 24  2015 pci-0000:00:12.0-usb-0:3:1.1-mouse -> ../../input/mouse2
lrwxrwxrwx 1 root root 18 Sep 24  2015 platform-i8042-serio-0-event-kbd -> ../../input/event1
lrwxrwxrwx 1 root root 18 Sep 24  2015 platform-i8042-serio-1-event-mouse -> ../../input/event5
lrwxrwxrwx 1 root root 18 Sep 24  2015 platform-i8042-serio-1-mouse -> ../../input/mouse0
lrwxrwxrwx 1 root root 18 Sep 24  2015 platform-pcspkr-event-spkr -> ../../input/event2
[root@alphaos ~]#

working on that bug report....
restarting vdev had no effect ..also tried un/replugging --nothing

I am not sure I understand what you are doing, booting tablet via
a usb HDD??

sorry, this sort of tablet https://buywacom.com.au/products/pen-ta ... small.html

other:
mpv/GMP fails looking for a libsystemd .so.... made/added libsystemd.sb , now works
can mpv be built without libsystemd? i see the systemd-dummy package on AUR lists libsystemd as a dep

gtk dark theme variant in spacefm bug: fixed for upcoming(1.04)release.
https://github.com/IgnorantGuru/spacefm/issues/578

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 24 Sep 2015, 14:38

efgee wrote:vdev took a long time to finish but after that the system was very responsive.

Would be interesting to compare with udev, I will see if I can take some measurements from alphaos 16

efgee wrote:One thing that I would like to see is to be able to get all applications as software bundles and be able to switch them on/off when I need/want it.
The best would be (I'm dreaming here...) if the main menu would show the software bundles and on clicking them they get activated and the app started. (suppose a config file would be needed with info like: software bundle dependency, name of app to start, etc.)

I am not sure I would like that however I would support you if you would like to try and set up your system that way.
I believe there is a puppy linux that does this, it may be lazypup but I am not sure



efgee wrote:So I removed evince and got it back (makesb evince) as bundle, however it's not working...
Maybe the installed version was an older one with less dependencies.
(same with termite, deadbeef...)
What about Voyager, GMPVideo, PlayTV, SimpleRadio how do I get rid of them?

I could possible put all of these in one separate apps bundle so you could just remove that one if you don't want them
There would be some trouble like menu's and openbox configuration, I have to give this some thought
For now there is bugs to fix so this would be a later thing.


efgee wrote:Want to do the same with all the other (no-system) apps but it's not as easy, as they might not be installed via the package manager.
Example: Geany does not show up with "pacman -Ss geany".

even if you would do a pacman -R on them they would still be existent in bundle extra_17.sb
which is a readonly squash archive.

if you then do makesb geany you will have two copies of geany loaded every time your system boots.

Maybe you could build your own version of extra_17.sb ???

efgee wrote:BTW: what is the init system? openrc/runit/sinit?

alphaOS use what is called busybox-init, in our case we use busybox in initramfs and toybox when booted
why it's so you have to ask simargl

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 24 Sep 2015, 15:00

Bought a mouse, got same behaviour as you

To my eye it looks like vdev creates the correct devices.

I will investigate further

ncmprhnsbl wrote:mpv/GMP fails looking for a libsystemd .so.... made/added libsystemd.sb , now works
can mpv be built without libsystemd? i see the systemd-dummy package on AUR lists libsystemd as a dep

That is kind of strange. I think it is possible to make it work without libsystemd

if you check on arch libsystemd required by you get

ceph
gnome-settings-daemon
libatasmart
libdbus
libgsystem
libgudev
openvpn
procps-ng
python2-systemd
python-systemd
rpcbind
systemd
usbip
util-linux
uwsgi
xf86-input-vmmouse
xorg-server-xnest


util-linux, libdbus and procps-ng is recompiled in alphaOS to not need libsystemd

no idea where it comes in, could it be an old udev dependency?

*EDIT*

checked up

Code: Select all

/usr/lib/libsamba-util.so.0:
      libsystemd-daemon.so.0 (LIBSYSTEMD_DAEMON_31) => not found

   /usr/lib/pulseaudio/libpulsecommon-6.0.so:
      libsystemd.so.0 (LIBSYSTEMD_209) => not found


So smbclient and libpulse needs to be recompiled, I did libpulse
not sure how to split package smbclient from samba guess I have to
take a look at arch ABS buildsystem, was inevitable for me to learn it

--------------------------------------------------------------------------------------------

ncmprhnsbl wrote:gtk dark theme variant in spacefm bug: fixed for upcoming(1.04)release.
https://github.com/IgnorantGuru/spacefm/issues/578

What do you mean?

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 24 Sep 2015, 15:39

Made a test on alphaos 16 with udev and vdev regarding USB mouse.

As reported works with udev and not vdev.
evdev doesn't get called with vdev as it does with udev
but evdev works for keyboard and touchpad with vdev????


I will try to compile latest vdev this weekend and test.

If this doesn't work should either you or me open an issue or github

If you open an issue there please inform me as well.

ncmprhnsbl
Competent
Posts: 36
Joined: 09 Nov 2013, 22:44

Re: version 17.1

Postby ncmprhnsbl » 24 Sep 2015, 23:54

re systemd free packages:
heres a guy doing an arch base iso using runit/eudev
http://bbs.archbang.org/viewtopic.php?id=5419
http://obarun.org/forum/index.php
heres some pkgbuilds of nosystemd packages:
https://github.com/Obarun/obarun-pkgbuild
Scooby wrote:
ncmprhnsbl wrote:gtk dark theme variant in spacefm bug: fixed for upcoming(1.04)release.
https://github.com/IgnorantGuru/spacefm/issues/578

What do you mean?

like this
Image
this isnt important tho :)

Scooby wrote:Bought a mouse, got same behaviour as you

my old serial mouse seems to be seriously faulty, causing major hardware freakout>hard shutdown>refuse to start even bios :o
at least it worked long enough to give some data...
btw my keyboard is serial plug (14 yrs!!!) so i wonder if a usb keyboard would work(i dont have one)

re conky atifacts
sleep 5 does the trick, bit extreme maybe less would do.... this might due to vdev and xorg not playing nicely?

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 25 Sep 2015, 19:40

ncmprhnsbl wrote:heres some pkgbuilds of nosystemd packages:

Thanks will check this out

ncmprhnsbl wrote:gtk dark theme variant in spacefm bug: fixed for upcoming(1.04)release.
https://github.com/IgnorantGuru/spacefm/issues/578

I can upgrade when I do fixes-release

ncmprhnsbl wrote:sleep 5 does the trick, bit extreme maybe less would do.... this might due to vdev and xorg not playing nicely?

Will test this, maybe reorder in .start

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 26 Sep 2015, 20:09

If you want usb mouse to work in the mean time try this

https://www.dropbox.com/s/ch7gj5v75fbo4 ... bd.sb?dl=0


*EDIT*

I tried latest vdev to see if it would play nice with USB-mouse but got another
error on missing /dev/dri instead so test was inconclusive


to ncmprhnsbl

for xf86-input-wacom there is a dependency on systemd so you can try
either to remove systemd-dummy and install real systemd and see if thats
working or recompile xf86-input-wacom


Thanks for the obarun links, shows how much must be recompiled

ncmprhnsbl
Competent
Posts: 36
Joined: 09 Nov 2013, 22:44

Re: version 17.1

Postby ncmprhnsbl » 27 Sep 2015, 09:43

Scooby wrote:If you want usb mouse to work in the mean time try this

mouse now working... also touchpad now has sideways scroll!
wacom tab now picked up as synaptic touchpad(its touch and pen)
no luck so far with systemd or rebuilt without... not sure what configure options
tried a 50-wacom.conf i found (from previous alpha)...with no effect

Code: Select all

Section "InputClass"
   Identifier "Wacom class"
   MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection

Section "InputClass"
   Identifier "Wacom serial class"
   MatchProduct "Serial Wacom Tablet"
   Driver "wacom"
EndSection

Section "InputClass"
        Identifier "Wacom serial class identifiers"
        MatchProduct "WACf|FUJ02e5|FUJ02e7|FUJ02e9"
        Driver "wacom"
EndSection

# Waltop tablets
Section "InputClass"
   Identifier "Waltop class"
   MatchProduct "WALTOP"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
EndSection

# N-Trig Duosense Electromagnetic Digitizer
Section "InputClass"
   Identifier "Wacom N-Trig class"
   MatchProduct "HID 1b96:0001|N-Trig Pen"
   MatchDevicePath "/dev/input/event*"
   Driver "wacom"
   Option "Button2" "3"
EndSection


also cant see/mount usb flash sticks ... appears in /dev
and is mountable manually(it then appears in spacefm)
then i can unmount and after i unplug it, an entry remains in spacefm
if i boot with it plugged in it is visible and mountable
but then if i unmount and unplug, an entry remains in spacefm

Scooby
Site Admin
Posts: 826
Joined: 09 Sep 2013, 16:52

Re: version 17.1

Postby Scooby » 27 Sep 2015, 14:55

ncmprhnsbl wrote:wacom tab now picked up as synaptic touchpad(its touch and pen)
no luck so far with systemd or rebuilt without... not sure what configure options
tried a 50-wacom.conf i found (from previous alpha)...with no effect

Could try to recompile with

Code: Select all

export XORG_PREFIX=/usr
export XORG_CONFIG="--prefix=$XORG_PREFIX --sysconfdir=/etc --localstatedir=/var --disable-static"

./configure $XORG_CONFIG --with-systemd-unit-dir=no

from LFS

I saw also a libwacom on arch? dunnow what that is for though?

The test_kbd.sb is just a temporary fix, this should be done with vdev.


ncmprhnsbl wrote:also cant see/mount usb flash sticks ... appears in /dev
and is mountable manually(it then appears in spacefm)
then i can unmount and after i unplug it, an entry remains in spacefm
if i boot with it plugged in it is visible and mountable
but then if i unmount and unplug, an entry remains in spacefm



Will test this, was workin in 16 with vdev


Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 4 guests

cron